stunthanger.com
News:
CLICK HERE---->    <----CLICK HERE
 
 
*
Welcome, Guest. Please login or register. March 29, 2015, 04:38:49 AM


Login with username, password and session length



Pages: [1]   Go Down
  Print  
Author Topic: Cox 049 High compression glow heads  (Read 32500 times)
Bernie Eisele
Guest
Trade Count: (0)
« on: August 14, 2009, 04:51:03 PM »

For those of you that have been waiting for Tee Dee glow heads, they are now in stock 

http://coxengines.ca/product.php?productid=200&cat=4&page=1

Bernie
Logged

Paul Smith
2014 Supporters
Trade Count: (0)
Admiral
*
Offline Offline

Age: 68
Posts: 3173



« Reply #1 on: July 02, 2012, 06:24:46 AM »

The glow head in your picture looks like a standard low compressionn head.  Not circle of stars on top and no trumpet shape inside.  Will you be offering a replacement for the higher performance TeeDee's and Black Widows?
Logged

Paul Smith
Bernie Eisele
Guest
Trade Count: (0)
« Reply #2 on: July 02, 2012, 09:39:43 AM »


They are 100% identical to the OEM Cox Tee Dee High-Compression glow heads except for the knurl (circle of stars) at the top.

We did not bother with the knurl as it would have cost another 50 cents and serves no purpose other than cosmetics to quickly differentiate it from the regular glow head. And, yes, the combustion chamber is trumpet shaped and identical to the ones Cox used to make.

See here:
http://coxengines.ca/cox-.049-tee-dee-glow-head.html

If you want the OEM packages ones, we still have a few in stock as well. See here:

http://coxengines.ca/cox-.049-tee-dee-glow-head-oem.html

Bernie
www.coxinternational.ca

Logged
Paul Smith
2014 Supporters
Trade Count: (0)
Admiral
*
Offline Offline

Age: 68
Posts: 3173



« Reply #3 on: July 04, 2012, 07:23:39 AM »

Thanks.  I don't really care about the decoration, on the combustion chamber.  Without a source of plugs, all the TeeDees and Black Widows will go by the wayside.  I've tried some of the adapter units, but always with a crippling loss of performance.
Logged

Paul Smith
Andy Bush
Trade Count: (0)
New Pilot
*
Offline Offline

Posts: 4


« Reply #4 on: Yesterday at 03:39:45 PM »

I have just purchased some of your 049 glow plugs to go along with my attempt to bring back to life engines that I had back in the 50s. I'm using new Cox gas, battery, etc and disassembled, cleaned, and then reassembled the engines (Golden Bees).

I'm not having much luck in starting them. My question is this. My memory is that the glow plug coil would turn reddish orange when tested...this was one way we would check for burned out plugs. I'm not seeing this at all with your new ones.

Also, I can't even get the engines to 'pop', let alone start. I can hear the glow plug 'sizzle' as I remember from back in the day. I'm priming as usual and making sure that I didn't flood the engine...to no avail.

Are these plugs supposed to glow red as I recall?

Any tips would be most appreciated.

Thanks!
Logged
Phil Krankowski
Trade Count: (0)
Captain
*****
Offline Offline

Location: Ohio
Posts: 476


« Reply #5 on: Yesterday at 04:41:33 PM »

Yes, these glow red.  In sunlight you might not be able to see it, even if you cup your hands.  Try in a darker space.  If it sizzles it is good. 

You can also put a small drop of fuel into the plug then hook it up and it will instantly boil out (and may catch fire, but only for an instant since it was a small drop of fuel!)

I suspect you are priming like a big engine (because of the sizzle), and spraying fuel into the OPEN exhaust port.  This floods the engine quite instantly.  Instead rotate the engine through till the exhaust is CLOSED and then let surface tension collect a drop of fuel in the exhaust port (only 1 of them).  Now when the engine is cycled through the correct amount of prime enters through the exhaust.

Now on a "dry" engine that has not been run in several days I do "flood" it, to make sure everything is wet with oil and fuel.  I clear the flood, fill the tank and then prime with the exhaust closed (like I just described).

Phil
Logged
Andy Bush
Trade Count: (0)
New Pilot
*
Offline Offline

Posts: 4


« Reply #6 on: Yesterday at 05:47:17 PM »

Yes, these glow red.  In sunlight you might not be able to see it, even if you cup your hands.  Try in a darker space.  If it sizzles it is good. 

Thanks, Phil. I was testing these plugs in the closed garage and was cupping my hand. No red glow at all. I tried putting a drop or so of fuel on the glow element expecting to see a bubbling as I remember from the past. All I got was a faint response. Voltmeter says the new battery is right at 1.5 volts. The Cox plug connector voltage checks OK too. I'm stumped!

Andy
Logged
Phil Krankowski
Trade Count: (0)
Captain
*****
Offline Offline

Location: Ohio
Posts: 476


« Reply #7 on: Yesterday at 07:43:12 PM »

hmm...OK.  So minimal response. 

What battery are you using?  If you are not using a 2D cell in parallel I would try one of those with fresh alkaline batteries.  I have a habit of suspecting power panels and rechargeable ignitors.  (Wire and tape work very well if you lack an alkaline tray, at least for a while.  These self-drain since you cannot break the circuit without taking it apart.  I made a tray from RadioShack parts when they were still around.)

If you are using an old Cox clip, I would suspect the wires, and probably clean the clip with some fine sandpaper.  The thin solid wires on those old clips break inside.  Get some lamp cord or speaker wire and replace the wire. 

Fire off an email message to Bernie, the contact link at the top of coxengines.ca if the 2 D cells don't light it up, and you are sure your wiring is good.  I would be stumped too.

Phil
Logged

Tags:
Pages: [1]   Go Up
  Print  
 
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.20 | SMF © 2013, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM